Stay in touch

Enter your email and get the latest news and researches on cybersecurity, receive invitations to private security events and conferences.

Local PHP File Inclusion in FluxBB

Advisory ID:HTB23246
Product:FluxBB
Vendor:FluxBB
Vulnerable Versions:1.5.7 and probably prior
Tested Version:1.5.7
Advisory Publication:December 31, 2014 [without technical details]
Vendor Notification:December 31, 2014
Vendor Fix:January 23, 2015
Public Disclosure:January 28, 2015
Latest Update:January 23, 2015
Vulnerability Type:PHP File Inclusion [CWE-98]
CVE Reference:CVE-2014-9574
Risk Level:High
CVSSv2 Base Score:7.6 (AV:N/AC:H/Au:N/C:C/I:C/A:C)
Solution Status:Fixed by Vendor
Discovered and Provided:High-Tech Bridge Security Research Lab
 

Advisory Details:

High-Tech Bridge Security Research Lab discovered vulnerability in FluxBB, which can be exploited to compromise vulnerable system.


1) Local PHP File Inclusion in FluxBB: CVE-2014-9574

The vulnerability exists due to absence of filtration of the "install_lang" HTTP GET parameter before including PHP files using the "require()" PHP function in "/install.php" script. The installation script "/install.php" remains on the system after installation by default and is accessible to anonymous users. A remote attacker can include and execute arbitrary "install.php" file from any directory on the server using directory traversal (e.g. "../") sequences. This may result in arbitrary PHP code execution and full system compromise.

A simple PoC below will include and execute "/tmp/install.php" script:

http://fluxbb/install.php?install_lang=../../../../../tmp/

Successful exploitation requires that attacker is able to plant a malicious "install.php" file on the system.


ImmuniWeb® On-Demand Web Application Penetration Test


Solution:
Update to FluxBB 1.5.8

More Information:
https://fluxbb.org/forums/viewtopic.php?id=8203


References:
[1] High-Tech Bridge Advisory HTB23246 - https://www.htbridge.com/advisory/HTB23246 - Local PHP File Inclusion in FluxBB.
[2] FluxBB - http://fluxbb.org/ - FluxBB is fast, light, user-friendly forum software for your website.
[3] Common Vulnerabilities and Exposures (CVE) - http://cve.mitre.org/ - international in scope and free for public use, CVE® is a dictionary of publicly known information security vulnerabilities and exposures.
[4] Common Weakness Enumeration (CWE) - http://cwe.mitre.org - targeted to developers and security practitioners, CWE is a formal list of software weakness types.
[5] ImmuniWeb® - web security platform by High-Tech Bridge for on-demand and continuous web application security, vulnerability management, monitoring and PCI DSS compliance.
[6] Free SSL/TLS Server test - check your SSL implementation for PCI DSS and NIST compliance. Supports all types of protocols.
User Comments
Add Comment


Have additional information to submit?
Please feel free to send us any additional information related to this Advisory, such as vulnerable versions, additional exploitation details and conditions, patches and other relevant details.